Дан массив 12 чисел. Вывести числа в порядке возрастания. Написать программу Pascal ABC .

0 голосов
31 просмотров

Дан массив 12 чисел. Вывести числа в порядке возрастания.

Написать программу Pascal ABC .


Информатика (125 баллов) | 31 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(12,-99,99);
  a.Println.OrderBy(t->t).Println
end.

Пример
56 -46 -48 87 31 6 -33 -66 32 20 6 40
-66 -48 -46 -33 6 6 20 31 32 40 56 87
(150k баллов)
0 голосов

Const n=12;
var
  a:array[1..n] of integer;
  i,j,t:integer;
begin
  Randomize;
  Writeln('Исходный массив:');
  for i:=1 to n do begin
    a[i]:=Random(51)-25;
    Write(a[i],' ')
  end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-i do
      if a[j]>a[j+1] then
      begin t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t end;
  Writeln('Отсортированный массив:');
  for i:=1 to n do Write(a[i],' ');
  Writeln
end.

Пример:
Исходный массив:
-6 -11 -1 -24 -15 23 14 -13 -5 3 17 -21
Отсортированный массив:
-24 -21 -15 -13 -11 -6 -5 -1 3 14 17 23

(194k баллов)