Тема одномерные массивы Написать программу в паскале: 1.Массив ** 15 значений заполнен...

0 голосов
64 просмотров

Тема одномерные массивы
Написать программу в паскале:

1.Массив на 15 значений заполнен случайными числами посчитать количество нечетных значений
2.Массив на 14 значений заполнен случайными числами второй сотни с точностью до десятых удалить все целые
3.Массив на 17 значений заполнен целыми числами вставить перед каждым полендромом
Число 10


Информатика (14 баллов) | 64 просмотров
Дан 1 ответ
0 голосов

Program one;
uses crt;
var
randomize;
i,s:byte;
a:array[1..15] of integer;
begin
for i:=1 to 15 do
begin
a[i]:=random(1000);
end;
for i:=1 to 15 do
begin
if odd(a[i]) then s:=s+1;
end;
writeln('ne4etnix 4isel-',s);
end.

как то так 1-я задача

(46 баллов)
0

хотя можно 2 цикла объединить в один и сразу после ввода проверять число на нечетность