Написать программу по блок схеме Паскаль АВС Сделайте пожалуйста Очень нужно

0 голосов
35 просмотров

Написать программу по блок схеме
Паскаль АВС
Сделайте пожалуйста
Очень нужно


image

Информатика | 35 просмотров
0

В блок схеме ошибка, содержимое блока условия и цикла местами поменялись

Дан 1 ответ
0 голосов

Var
  Y, Z: array[1..10000] of integer;
  n, i, k: integer;
Begin
  Write('n = ');ReadLn(n);
  For i := 1 to n do
  Begin
    Write('Y[',i,'] = ');ReadLn(Y[i]);
  End;
  k := 0;
  For i:= 1 to n do
    if (Y[i] < 0) then
    Begin
      k := k+1;
      Z[k] := Y[i];
    End;
  For i:= 1 to n do
    if (Y[i] > 0) then
    Begin
      k := k+1;
      Z[k] := Y[i];
    End;
  For i:= 1 to n do
    if (Y[i] = 0) then
    Begin
      k := k+1;
      Z[k] := Y[i];
    End;
  Write('Y:');
  For i:= 1 to n do
    Write(' ',Y[i]);
  WriteLn;
  Write('Z:');
  For i:= 1 to n do
    Write(' ',Z[i]);
End.

(6.6k баллов)