Напишите программу, которая заполняет массив из 16 элементов случайными числами **...

0 голосов
48 просмотров

Напишите программу, которая заполняет массив из 16 элементов случайными числами на отрезке [-4;4] находит произведение ненулевых элементов.
СРОЧНО! ДАЮ 50 БАЛЛОВ!


Информатика (193 баллов) | 48 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(16,-4,4); a.Println;
  a.Where(t->t<>0).Aggregate(1,(i,j)->i*j).Println
end.

Пример
-2 -1 1 -3 -2 2 0 -4 0 2 4 -2 -4 4 3 -1
73728
(150k баллов)
0 голосов

Program fpro;

var
a : array[1..16] of integer;
i,p : integer;

begin
randomize;
p:=1;
for i :=1 to 16 do begin 
a[i] := random(-4,4); 
if (a[i] <> 0) then p:=p* a[i]; 
write(a[i]+' ');
end;
writeln();
write('Произведение = ', p);
end.

(314k баллов)