Помогите пожалуйста Напишите программу ** языке Паскаль для решения задачи Дано...

0 голосов
14 просмотров

Помогите пожалуйста Напишите программу на языке Паскаль для решения задачи


Дано четырёхзначное число Х. Найти:
a. число десятков в нем;
b. число единиц в нем;
c. число сотен в нем;
d. число тысяч в нем;
e. сумму его цифр;
f. произведение его цифр.


Информатика (16 баллов) | 14 просмотров
Дан 1 ответ
0 голосов

Uses crt;
var input, betw:integer;
begin         
readln(input);                  
betw := input;          
betw := betw div 10;         
betw := betw div 10;         
betw := betw div 10;
      
writeln('Тысяч = ', betw); 
                
betw := input;         
betw := betw div 10;         
betw := betw div 10;         
betw := betw mod 10;                  
writeln('Сотен = ', betw);                 
betw := input;         
betw := betw div 10;         
betw := betw mod 10;                  
writeln('Десятков = ', betw);                           
betw := input;         
betw := betw mod 10;                  
writeln('Единиц = ', betw);        end.

(404 баллов)