Напишите программу, которая заполняет массив из N элементов случайными целыми числами в...

0 голосов
362 просмотров

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет среднее арифметическое элементов этого массива.


Входные данные

Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .


Выходные данные

В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – среднее арифметическое элементов этого массива, сохранив три знака в дробной части.


Информатика (25 баллов) | 362 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,n):=ReadInteger3;
  var p:=ArrRandom(n,a,b); p.Println;
  Writeln(p.Average:0:3)
end.
(150k баллов)
0

Мне нужно в питоне а не в паскале!!!

0

Или в Free Pascal 3.0.2!!

0

точно

0 голосов

Var c:array[1..10000] of integer;
n, k, S, a, b: integer;
q: real;

begin
read(a, b, n); 
k:=0; S:=S;
for var i:=1 to n do begin  
c[i]:=random(a,b); 
k:=k+1;  
S:=S+c[i];  
write(c[i], ' ');
end;
q:=S/k;
writeln(q:17:3);
end.

(314k баллов)
0

какую?

0

у вас какой паскаль ?

0

abc ?

0

питон

0

ты не сказал какой язык программирования

0

SyntaxError на строке 2: invalid syntax (вот что пишет)

0

Я на паскале решил

0

исправил

0

не то