Напишите программу, которая при вводе Х и У . выдаёт сообщение о принадлежности точки...

0 голосов
57 просмотров

Напишите программу, которая при вводе Х и У . выдаёт сообщение о принадлежности точки заштрихованным областям, надеюсь на вашу помощь)
Если не видно:
Х^2+У^2=2^2
У=-х
Х=-2


image

Информатика (15 баллов) | 57 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,y: real;
begin
write('x = '); readln(x);
write('y = '); readln(y);
if (x*x+y*y>=2*2)and(y<=-x)and(x>=-2)and(y>=0)
  then writeln('Да')
  else writeln('Нет');
end.

Пример:
x = -1.9
y = 1.9
Да

(194k баллов)