90 баллов!!Помогите написать программу в Паскаль. 2 задача. Надо решить через цикл с параметром
var fio1, foi2: string; rez1, rez2, rez3: integer; sum1, sum2: integer; Begin readln(fio1, rez1, rez2, rez3); sum1 := rez1 + rez2 + rez3; readln(fio2, rez1, rez2, rez3); sum2 := rez1 + rez2 + rez3; If (sum1>sum2) writeln(fio1); else writeln(fio2);
через цикл с параметром нужно
program dassa; uses crt; var a1:array[1..4] of integer; a2:array[1..4] of integer; i:integer; s1,s2:real; begin clrscr; s1:=0; s2:=0; writeln('Введите оценки первого ученика'); for i:=1 to 4 do read(a1[i]); writeln('Введите оценки воторго ученика '); for i:=1 to 4 do read(a2[i]); for i:=1 to 4 do begin s1:=s1+a1[i]; s2:=s2+a2[i]; end; if (s1/4)>(s2/4) then writeln('Первый лучше') else begin if s1=s2 then writeln( 'Одинакого' ) else writeln ('Второй лучше'); end; end.