Написать программу для подсчета суммы введенных с клавиатуры чисел до тех пор, пока не...

0 голосов
83 просмотров

Написать программу для подсчета суммы
введенных с клавиатуры чисел до тех пор, пока не будет
введен 0.


Информатика (15 баллов) | 83 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,s:integer;
begin
s:=0;
readln(a);
while a<>0 do
 begin
 s:=s+a;
 readln(a);
 end;
writeln('s = ',s);
end.

Пример:
5
8
3
4
6
0
s = 26

(194k баллов)
0

Спасибо

0

Пожалуйста.

0 голосов

//PascalABC.NET
//Версия 3.3, сборка 1634
begin
write(ReadSeqIntegerWhile(x->x<>0).Sum);
end.

(149k баллов)