Помогите написать программу с++, я не понимаю как искать одинаковые слова в строке

0 голосов
48 просмотров

Помогите написать программу с++, я не понимаю как искать одинаковые слова в строке


image

Информатика (184 баллов) | 48 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Как то так
-------------


image
(799 баллов)
0 голосов
#include
#include
#include
#include
using namespace std;  
typedef unordered_set my_set;  
int main()
{
     string tmp, in = "hello world friend hello world hello";
     my_set us;
     stringstream ss;
     ss << in;<br>     while (ss >> tmp)  us.insert(tmp);
     for (auto i : us) cout << i << " ";<br>     system("pause");
}
(4.2k баллов)