Написать программу для Pacsal. Заданы два целых числа найти сумму их последних цифр.

0 голосов
44 просмотров

Написать программу для Pacsal. Заданы два целых числа найти сумму их последних цифр.


Информатика (135 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
1. Современное решение с числами произвольной длины

// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString('1-е число:');
  var s2:=ReadlnString('2-е число:');
  Writeln('Сумма последних цифр: ',s1.Right(1).ToInteger+s2.Right(1).ToInteger)
end.

Пример
1-е число: 23454577562342341234213141652
2-е число: 35645675786956323224
Сумма последних цифр: 6

2. Типовое "школьное" решение

var
  a, b: integer;

begin
  Write('Введите два числа через пробел: ');
  Read(a, b);
  Writeln('Сумма последних цифр: ', a mod 10 + b mod 10)
end.

Пример
Введите два числа через пробел: 435345
6342
Сумма последних цифр: 7
(150k баллов)