Написать программу ** паскале Заполнить линейный массив по формуле c[i]=i^2+d*√i

0 голосов
34 просмотров

Написать программу на паскале
Заполнить линейный массив по формуле c[i]=i^2+d*√i


Информатика (418 баллов) | 34 просмотров
0

незнаю наверное вводится с клавиатуры

Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var d:=ReadReal('d=');
  var c:=ArrGen(ReadInteger('n='),i->i*i+d*Sqrt(i));
  c.Println
end.

Пример
d= 2.183
n= 10
0 3.183 7.08722820666047 12.7810669129229 20.366 29.881336394882 41.3472361084957 54.775675112054 70.1744564133209 87.549
(150k баллов)
0 голосов

Шя бахним пониль да

Program TuKpa6noJlHbiII;const n=5;vard,i:integer;c:array[1..n] of real;BEGINfor i:=1 to n do  begin    c[i]:=sqr(i)+d*sqrt(i);    writeln(c[i]);  end;  writeln('MaceB paBuH');  writeln('Ha)|(Mu Enter gJl9 Bbixoga');  readln;END.

(2.8k баллов)