Напишите программу на Pascal для решения системы уравнений:
это не система уравнений, это - кусочно-заданная функция
Именно поэтому я не совсем поняла задание и спрашиваю здесь.
скорей всего это задание на условный оператор
Program test; uses crt; var y,x:integer; begin textcolor(11); writeln('Введите x: '); readln(x); if x>2 then begin y:=x*x; writeln('Ответ: ', y) end else begin y:=4; writeln('Ответ: ', y); end; end.