Даны 4 целых числа. Найти сумму и количество чётных чисел то есть написать программу

0 голосов
51 просмотров

Даны 4 целых числа. Найти сумму и количество чётных чисел то есть написать программу


Информатика (12 баллов) | 51 просмотров
0

массив?

Дан 1 ответ
0 голосов

Const
    handsfree = false;
    nmax = 4;
    random_min = -50;
    random_max = 50;

var
    a: array[1..nmax] of integer;
    i, n, j: integer;
    sum, product, harmonic: real;
    k: integer;

begin
    {ввод массива}
    n := nmax;
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(random_max - random_min) + random_min;
            write(a[i], ' ');
        end
        else
            readln(a[i]);
    end;
    writeln();
    
    {подсчет элементов}
    k := 0;
    for i := 1 to n do
        if a[i] mod 2 = 0 then
            k := k + 1;
    writeln('quantity = ', k);
    
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    for i := 1 to n do
        sum := sum + a[i];
    writeln('sum = ', sum);
end.

(53.1k баллов)