Напишите программу ** языке программирования Паскаль в результате выполнения которого...

0 голосов
25 просмотров

Напишите программу на языке программирования Паскаль в результате выполнения которого получалась сумма всех элементов массива


Информатика (39 баллов) | 25 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  Writeln('S=',a.Sum)
end.

Пример
n= 13
-33 4 19 46 -23 19 -32 31 -10 48 -13 -32 -10
S=14
(150k баллов)
0 голосов

Var a: array  [1..20] of integer;    i: integer;    sum: integer;begin
 sum:=0; for i:=1 to 20 do begin                   a[i] := random(20);                   write(a[i],' ');                   sum:= sum+a[i];              end;               writeln(); writeln('Сумма всех элементов : ',sum); end.

(64 баллов)