Нужно написать программу ** с++ мы вводим массив из букв, а программа должна их...

0 голосов
61 просмотров

Нужно написать программу на с++
мы вводим массив из букв, а программа должна их отсортировать по алфавиту


Информатика (1.1k баллов) | 61 просмотров
0

Какой используется алфавит?

0

английский

Дан 1 ответ
0 голосов
Правильный ответ

#include
#include

using namespace std;

int main()
{
    string S;
    cin >> S;
    int Mass[52];
    for (int i = 0; i < 52; i++)
    {
        Mass[i] = 0;
    }
    for (int i = 0; i < S.length(); i++)
    {
        char c = S[i];
        if (c >= 'a'&&c <= 'z')<br>        {
            Mass[(int)(c-'a')*2]++;
        } else if (c >= 'A'&&c <= 'Z'){<br>            Mass[(int)(c-'A')*2+1]++;
        }
    }
    for (int i = 0; i < 52; i++)
    {
        for (int j = 0; j < Mass[i]; j++)
        {
            cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));<br>        }
    }
    return 0;
}

Пример работы программы:

LKDKjgkjsdlfvkhnOLHDSKLJNFLjghlJNKSgbakjbjkHVLJhfvkjHVKJAyfjHLIhaLIUYGFLAkjbhdilAUGXIKJASILFYHGklajfbhliGFLKjblkJBDFIgiksjbnfowshKLJH

aaaAAAAbbbbbbBddDDDfffffFFFFFggggGGGGhhhhhhhHHHHHHiiiIIIIIjjjjjjjjjjjJJJJJJJkkkkkkkkkKKKKKKKKllllllLLLLLLLLLLLnnNNoOsssSSSUUvvVVwXyYY

(6.6k баллов)