Составьте программу которая возводит число X в восьмую степень. Даю 40 очков.

0 голосов
44 просмотров

Составьте программу которая возводит число X в восьмую степень.
Даю 40 очков.


Информатика (28 баллов) | 44 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

X⁸ = ( (x²)² )²

// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var x8:=Sqr(Sqr(Sqr(ReadReal('x='))));
  Writeln('x^8=',x8)
end.

Пример
x= 3.17
x^8=10197.0394089246

(150k баллов)
0 голосов

Var a:integer;
a:=strtofloat(edit1.text);
a:=a*а*а*а*а*а*а*а;
label1.text:= floattostr(a);

(1.1k баллов)
0

делфи , почему ты решил что это отгрызок?