Помогите по информатике! Составьте программу заполнения массива из 100 чисел случайными...

0 голосов
42 просмотров

Помогите по информатике!
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений


Информатика (107 баллов) | 42 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(100,-20,20); a.Println;
  Writeln('Положительных ',a.Where(t->t>0).Count,
      ', отрицательных ',a.Where(t->t<0).Count);<br>end.

Пример в прилагаемом скриншоте
(150k баллов)
0 голосов

На скриншотах
==============


image
image
(60.5k баллов)