Напишите программу которая будет переводить из 10 системы с счисления в любую другую ( в...

0 голосов
63 просмотров

Напишите программу которая будет переводить из 10 системы с счисления в любую другую ( в том числе должны быть отрицательные числа и не только целые) было бы неплохо ещё засчиту от дебилов(чтобы можно было упасть на клаву и программа не сломалась) очень прошу.


Информатика (15 баллов) | 63 просмотров
0

ну до 36

0

как удобней

0

нам не дали конкретно, как удобней так и сдлеай

0

да

Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!

function DecToa(n:string;k:integer):string;
// Перевод из десятичной системы в систему по основанию k
begin
  var s:='0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ';
  Result:='';
  var PointPos:=Pos('.',n);
  var IntPart:integer;
  if PointPos>0 then begin // есть дробная часть
    var FracPart:=Frac(n.ToReal);
    var m:=0;
    while True do begin
      var r:=FracPart*k;
      Result+=s[Trunc(r)+1];
      FracPart:=Frac(r);
      m+=1;
      if (m=15) or (FracPart=0) then break
      end;
    IntPart:=n[:PointPos].ToInteger;
    end
  else IntPart:=n.ToInteger;
  if Result<>'' then Result:='.'+Result;
  while IntPart>0 do begin
    Result:=s[IntPart mod k+1]+Result;
    IntPart:=IntPart div k
    end;
  if Result='' then Result:='0';
  if Result[1]='.' then Result:='0'+Result
end;

begin
  var n:=ReadlnString('Какое число перевести?');
  var p:real;
  if not real.TryParse(n,p) then Writeln('Такая запись недопустима')
  else
    if n.Contains('e') or n.Contains('E') then
      Writeln('Запись в экспоненциальном формате не разрешена')
    else begin
      var k:=ReadInteger('Укажите основание системы:');
      if k.Between(2,36) then     
          Writeln(n,'(10) = ',n[1],DecToA(n[2:],k),'(',k,')')
      else Writeln('Допустимы основания 2..36')
      end
end.

Примеры
Какое число перевести? 123,5433
Такая запись недопустима

Какое число перевести? -353.093234
Укажите основание системы: 21
-353.093234(10) = -GH.1K2951B0DJAH1BI(21)

Какое число перевести? 6523
Укажите основание системы: 8
6523(10) = 61013(8)

Какое число перевести? 1.2e-18
Запись в экспоненциальном формате не разрешена
(150k баллов)
0

что такое k.Between?

0

окей, а ты не подскажешь где ты скачал эту версию ?

0

я чет не могу её найти