Написать программу по блок-схеме.

0 голосов
31 просмотров

Написать программу по блок-схеме.


image

Информатика (24 баллов) | 31 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('Введите a и b через пробел:');
  var (S,G):=((a+b)/2,Sqrt(a*a+b*b));
  Println(S,G)
end.

Пример
Введите a и b через пробел: 13.45 18
15.725 22.470035602998
(150k баллов)
0 голосов

Var
  a, b, s, g: real;

begin
  readln(a, b);
  s := (a + b) / 2;
  g := sqrt(a * a + b * b);
  writeln('s = ', s:0:6);
  writeln('g = ', g:0:6);
end.

(1.0k баллов)