Программисты помогите! надо написать программу ** паскале, найти произведение...

0 голосов
37 просмотров

Программисты помогите! надо написать программу на паскале, найти произведение отрицательных элементов массива.


Информатика (96 баллов) | 37 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  a.Where(t->t<0).Aggregate(BigInteger(1),(p,q)->p*q).Println
end.

Пример
n= 15
-44 -33 -7 48 14 44 -14 -14 -45 -13 16 47 -48 19 -14
-783151649280
(150k баллов)
0 голосов

Program n1;
var a: array[1..10] of integer;
i,p: integer;
begin
randomize;
write('массив: ');
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]<0 then p:=p*a[i];<br>end;
writeln;
write('произведение отрицательных: ',p)
end.

(149k баллов)