Помогите написать программу ** C++

0 голосов
53 просмотров

Помогите написать программу на C++


image

Информатика (5.5k баллов) | 53 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

#include
#include   //#include

using namespace std;

float AreaHero(float s1, float s2, float s3)
{
    float p, s;
    p = (1.0 / 2.0) * (s1 + s2 + s3);
    s = sqrt(p * (p - s1) * (p - s2) * (p - s3));
    return s;
}

int main()
{
    float a, b, c, p, l, f;
    cout << "Ввод сторон первого треугольника." << endl;<br>    cout << "a = "; cin >> a;
    cout << "b = "; cin >> b;
    cout << "c = "; cin >> c;
    
    cout << "Ввод сторон второго треугольника." << endl;<br>    cout << "p = "; cin >> p;
    cout << "l = "; cin >> l;
    cout << "f = "; cin >> f;
    
    AreaHero(a, b, c);
    cout << "Площадь первого треугольника = " << AreaHero(a, b, c) << endl;<br>    cout << "Площадь второго треугольника = " << AreaHero(p, l, f) << endl;<br>
    //system("pause");
    return 0;
}

(9.4k баллов)
0 голосов

#include
#include
using namespace std;

double ST(double a, double b, double c)
{
    double p = (a+b+c)/2;
    return sqrt(p*(p-a)*(p-b)*(p-c));
}

int main()
{
    double a,b,c;
    cout << "Введите длины сторон первого треугольника: ", cin >> a >> b >> c;
    cout << "\nПлощадь первого треугольника: " << ST(a,b,c);<br>    cout << "\nВведите длины сторон первого треугольника: ", cin >> a >> b >> c;
    cout << "\nПлощадь второго треугольника: " << ST(a,b,c);<br>    return 0;
}

(6.6k баллов)