Помогите написать программу ** C++(2) Вложение

0 голосов
49 просмотров

Помогите написать программу на C++(2)
Вложение


image

Информатика (5.5k баллов) | 49 просмотров
0

Если не пишите компилятор - программа может у Вас не запуститься.

0

int SA(int a, int b, int c, int d) //Среднее арифметическое{ result (a+b+c+d)/4;}

0

Хотя почему int, там должно быть double

0

Пока не за что

Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;

double SA(double a, double b, double c, double d)
{
    return ((a+b+c+d)/4);
}

double SG(double a, double b, double c, double d)
{
    return sqrt(sqrt(a*b*c*d));
}

int main()
{
    double a,b,c,d;
    cout << "Введите четыре числа: ", cin >> a >> b >> c >> d;
    cout << "Их среднее арифметичекое: " << SA(a,b,c,d);<br>    cout << "\nИх среднее геометрическое: " << SG(a,b,c,d);<br>    return 0;
}

(6.6k баллов)