Написать программу Pascal с помощью команд if then else. Есть прямоугольное отверстие с...

0 голосов
64 просмотров

Написать программу Pascal с помощью команд if then else. Есть прямоугольное отверстие с размерами а и b. Пройдет ли в это отверстие балка восотой m и шириной n


Информатика (17 баллов) | 64 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Чтобы предмет с прямоугольным поперечным сечением a×b прошел в прямоугольное отверстие размером m×n, нужно чтобы минимальный размер стороны отверстия был больше минимального размера в сечении предмета, а максимальный размер стороны отверстия был больше максимального размера в сечении предмета.
Выражение min(a,b) < min(m,n) ∧ max(a,b) < max(m,n) должно принимать значение "истина".

PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('Введите через пробел размеры балки:');
  var (m,n):=ReadReal2('введите через пробел размеры отверстия:');
  if  (Min(a,b)    Writeln('Балка проходит в отверстие')
  else Writeln('Балка не проходит в отверстие')
end.

Пример
Введите через пробел размеры балки: 3.6 4.8
введите через пробел размеры отверстия: 4.2 4
Балка не проходит в отверстие

(150k баллов)