Нужно написать программу нахождения большего из 4 чисел Срочно Заранее огромное спасибо

0 голосов
211 просмотров

Нужно написать программу нахождения большего из 4 чисел
Срочно
Заранее огромное спасибо


Информатика (25 баллов) | 211 просмотров
Дан 1 ответ
0 голосов

Program Maximum;

var
  x1, x2, x3, x4, m: integer;

function max(a, b: integer): integer;
begin
  if a > b
    then max := a
  else max := b
end;

begin
  write('Введите 4 числа: ');
  readln(x1, x2, x3, x4);
  m := max(x1, max(x2, max(x3, x4)));
  writeln('Максимальное: ', m);
end.


image
(2.3k баллов)