Паскаль. Напишите программу, которая запрашивает ввод массива B и выводит ** экран его...

0 голосов
50 просмотров

Паскаль.
Напишите программу, которая запрашивает ввод массива B и выводит на экран его элементы в табличной форме:

1 2 3 4
2 3 4 5
3 4 5 6

Выведите на экран среднее арифметическое элементов массива B.


Информатика (63 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  var b:=ReadMatrInteger(m,n);
  b.Println(4); Writeln(4*b.ColCount*'-');
  Writeln('Ср.арифм. равно ',b.ElementsByRow.Average)
end.

Пример
Количество строк и столбцов в массиве: 3 4
1 2 3 4
2 3 4 5
3 4 5 6
   1   2   3   4
   2   3   4   5
   3   4   5   6
----------------
Ср.арифм. равно 3.5
(150k баллов)