Напишите программу, которая выводит ** экран таблицу умножения ** n ( n-целое число в...

0 голосов
264 просмотров

Напишите программу, которая выводит на экран таблицу умножения на n ( n-целое число в диапазоне от 2 до 10, вводимое с клавиатуры), Паскаль. В цикле while или repeat until


Информатика (28 баллов) | 264 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  if n.Between(2,10) then begin
    var i:=1;
    repeat
      Write(n,'x',i,'=',n*i,' ');
      i+=1
    until i>10;
    Writeln
    end
  else Writeln('Число должно быть от 2 до 10')
end.

Пример
n= 6
6x1=6 6x2=12 6x3=18 6x4=24 6x5=30 6x6=36 6x7=42 6x8=48 6x9=54 6x10=60
(150k баллов)
0

ReadInteger что это такое? Как объяснить информатику в школе)) Нам про такое не говорили

0

Загружаете программу, наводите курсор на непонятное слово - там все написано по-русски, что это и что оно делает. А то, чтго Вы учили, и что нет - откуда мне знать?

0

Вам могут не говорить про 95% того, что в языке есть... это от конкретного учителя зависит

0

Ну ладно. Большое вам спасибо

0

Добавил Вам картинку, как смотреть непонятное

0 голосов

Лови 
program znaniya;
var n,i:integer;
begin
write('Введите n ');
read(n);if (n<2) or (n>10) then 
begin
while (n<=1) or (n>10) do
 begin
writeln('Ошибка! Число n должно быть в диапазоне от 2 до 10');
write('Введите n ');read(n);
end;
end;
for i:=1 to 10 do writeln(n,'*',i,'=',n*i);
end. 

(48 баллов)