Помогите написать программу к этой блоксхеме.

0 голосов
38 просмотров

Помогите написать программу к этой блоксхеме.


image
image

Информатика (26 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

Надеюсь я правильно понял что второй блок это ввод данных
на пайтоне это так:
a =(input)
b= (input)
x= (input) 
if x >= a and x<=b:<br>   print("Да")
else:
       print("Нет")
я надеюсь все правильно разобрал:)
На паскале (в паскале не уверен, проверяйте сами)
var 
     a: integer;
     b: integer;
     x: integer;
begin
           readln (a);
           readln (b);
           readln (x);
           if (x>=a) and (x<=b) then write ('Да')<br>           else write ('Нет')
end
в общем как-то так
         

(182 баллов)
0

Мы в Паскале работаем.

0

оу

0

ну, прости, зато теперь ты знаешь как это выглядит на пайтоне:)

0

на ходу изучая паскаль решаю

0

Я сделала,но не уверена,что правильно. В общем.

0

If x>=a and x<=b then writeln(' Да') else writeln ('Нет'); end.

0

компилятора на паскаль у меня нет, поэтому проверить не могу