Паскаль Написать программу для нахождения суммы большего и меньшего из трех чисел....

0 голосов
85 просмотров

Паскаль
Написать программу для нахождения суммы большего и меньшего из трех чисел. Указание: для решения задачи использовать подпрограммы вычисления минимального и максимального для двух чисел.
Пример
на входе: 45 72 24
на выходе: 96


Информатика (1.0k баллов) | 85 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a, b, c: integer;

function min_3(const a, b, c: integer): integer;
var
  local_min: integer;
begin
  if (a < b) then
    local_min := a
  else
    local_min := b;
      if (c < local_min) then
    local_min := c;
      Result := local_min
end;

function max_3(const a, b, c: integer): integer;
var
  local_max: integer;
begin
  if (a >= b) then
      local_max := a
  else
      local_max := b;
       
  if (c > local_max) then
      local_max := c;

  Result := local_max;
end;

begin
  writeln('Введите a, b, c -> ');
  readln(a, b, c);
  writeln('Результат: ', min_3(a, b, c) + max_3(a, b, c), '.');
end.

(4.9k баллов)