Напишите программу которая вводит натуральное число n и выводит n квадратов из символов...

0 голосов
75 просмотров

Напишите программу которая вводит натуральное число n и выводит n квадратов из символов "@".
Ввод:
3
Вывод:
@@@ @@@ @@@
@ @ @ @ @ @
@@@ @@@ @@@


Информатика (15 баллов) | 75 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
{ Ответ дан на языке Pascal }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  n: INTEGER;
  I: INTEGER;
  Str: STRING;

BEGIN
  WRITE('Введите кол-во квадратов: ');
  READLN(n);
  STR := '@@@ ';
  FOR I := 2 TO n
  DO
  BEGIN
    Str := Str + COPY(Str, 1, 4);
  END;
  WRITELN(Str);
  WRITELN(Str);
  WRITELN(Str);
END.
(66 баллов)