1)Напишите программу, которая вводит два целых числа и находит их произведение, не...

0 голосов
440 просмотров

1)Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.

Входные данные
Входная строка содержит два целых числа.

Выходные данные
Программа должна вывести произведение введённых чисел.

Примеры
входные данные
6 12
выходные данные
72
входные данные
-7 15
выходные данные
-105
2)Напишите программу, которая вводит натуральное число N и находит сумму всех натуральных чисел от 1 до N .

Входные данные
Входная строка содержит единственное целое число N .

Выходные данные
Программа должна вывести сумму натуральных чисел от 1 до введённого числа N .

Примеры
входные данные
100
выходные данные
5050
3)Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b .

Входные данные
Входная строк содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] .

Примеры
входные данные
2 5
выходные данные
54
4)Напишите программу, которая вводит натуральные числа a , b и N , и выводит на экран N псевдослучайных целых чисел на отрезке [ a , b ] .

Входные данные
Входная строка содержит три числа, разделённые пробелами: границы отрезка a и b и требуемое количество чисел N . Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести N случайных целых чисел в одной строке, разделив их пробелами.

Примеры
входные данные
10 20 5
выходные данные
10 10 19 12 13
ЗА ВСЁ РЕШЕНИЕ 99 БАЛЛОВ!!!!!!!
ПОМОГИТЕ РЕШИТЬ ПОЖАЛУЙСТА!!!!


Информатика (112 баллов) | 440 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

1)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
if (a<0)and(b<0) then<br> begin a:=-a; b:=-b; end;
if a<0 then for var i:=1 to b do s+=a<br>else for var i:=1 to a do s+=b;
WriteLn(s);
end.

Пример:
-7 15
-105

2)
var n,s:integer;
begin
Readln(n);
s:=0;
for var i:=1 to n do s+=i;
WriteLn(s);
end.

Пример:
100
5050

3)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
for var i:=a to b do s:=s+i*i;
writeLn(s);
end.

Пример:
2 5
54

4)
var a,b,n:integer;
begin
Readln(a,b,n);
for var i:=1 to n do write(random(b-a+1)+a,' ');
end.

Пример:
10 20 5
11 12 14 14 18

(194k баллов)
0

var a,b,s,n:Integer;
begin
Read(a,b);
for n:= 1 to abs(b) do
s+=a;
if b<0 then <br>s:=-s;
WriteLn(s);
end.

0 голосов

1)
var a,b,s:Integer;
begin
Read(a,b);
if(a<0) and (b<0) then<br>a:= abs(a);
for var n:= 1 to abs(b) do
s+=a;
WriteLn(s);
end.
2)
var a,s:Integer;
begin
Read(a);
for var n:= 1 to a do
s+=n;
WriteLn(s);
end.
3)
var a,b,s:Integer;
begin
Read(a,b);
for var n:=a to b do
s+=n*n;
WriteLn(s);
end.
4)
var a,b,n:Integer;
begin
Randomize;
Read(a,b,n);
for var q:=1 to n do
Write(Random (b+1-a)+a+' ');
end.

(614 баллов)
0

Проверьте в задаче 1) 15 и -7.

0

Спасибо.Сейчас исправлю