** с++ Напишите программу, которая строит "линию" из знаков '-' заданной длины....

0 голосов
299 просмотров

На с++
Напишите программу, которая строит "линию" из знаков '-' заданной длины. Используйте процедуру.

Входные данные
Входная строка содержит единственное натуральное число – длину линии N .

Выходные данные
Программа должна вывести N знаков '-'.

Примеры
входные данные
5
выходные данные
-----


Информатика (340 баллов) | 299 просмотров
Дан 1 ответ
0 голосов

//g++  5.4.0

#include
using namespace std;

void foo(size_t n)
{
    for (int i = 0; i < n; ++i) {
        cout << '-';<br>    }
}

int main()
{
    size_t n;
    cin >> n;

    foo(n);
}

(4.2k баллов)
0

о, а что за обновление дизайна на сайте

0

Дохлый Страус )))

0

похоронили при жизни))

0

это только у нас эта фамилия так читается))

0

вероятно