** С++ Напишите программу, которая переводит переданное её целое число (возможно,...

0 голосов
180 просмотров

На С++
Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру.

Входные данные
Входная строка содержит целое число N .

Выходные данные
Программа должна вывести двоичное представление переданного её числа.

Примеры
входные данные
5
выходные данные
101
входные данные
-14
выходные данные
-1110


Информатика (340 баллов) | 180 просмотров
Дан 1 ответ
0 голосов

//g++  5.4.0
#include
using namespace std;

long long convert(int n)
{
    long long binaryNumber = 0;
    int remainder, i = 1;

    while (n!=0)
    {
        remainder = n%2;
        n /= 2;
        binaryNumber += remainder*i;
        i *= 10;
    }
    return binaryNumber;
}

int main()
{
    size_t num;
    cin >> num;

    cout << convert(num);<br>}

(4.2k баллов)