** с++ Напишите программу, которая находит в массиве количество элементов, равных...

0 голосов
151 просмотров

На с++
Напишите программу, которая находит в массиве количество элементов, равных заданному значению X .

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести одно числа – количество элементов массива, равных X .

Примеры
входные данные
6
1 2 3 2 3 3
2
выходные данные
2


Информатика (340 баллов) | 151 просмотров
Дан 1 ответ
0 голосов

//g++  5.4.0

#include
#include
#include
using namespace std;

int main()
{
    size_t N, num;
    cin >> N >> num;
    vector a(N);
   
    for (size_t i = 0; i < N; ++i) 
        cin >> a[i];

    cout << count(a.begin(), a.end(), num);<br>}

(4.2k баллов)
0

не верно работает

0

напишите лучше сами