** С++ Напишите программу, которая вычисляет сумму элементов матрицы. Входные данные В...

0 голосов
276 просмотров

На С++
Напишите программу, которая вычисляет сумму элементов матрицы.

Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.

Выходные данные
Программа должна вывести одно число – сумму элементов матрицы.

Примеры
входные данные
4 5
1 2 3 4 5
6 12 8 9 10
11 12 12 14 15
16 17 18 12 20
выходные данные
207


Информатика (340 баллов) | 276 просмотров
0

Обязательно мвтрицу делать?

0

можно же просто считать M×N чисел и сразу складывать

Дан 1 ответ
0 голосов

//g++  5.4.0

#include
#include
using namespace std;
int main()
{
    size_t N, M, sum{ 0 };
    cin >> N >> M;
    vector> v(N, vector(M));
    for (size_t i = 0; i < N; ++i) {
        for (size_t j = 0; j < M; ++j) {
            cin >> v[i][j];
            sum += v[i][j];
            cout << v[i][j] << " ";<br>        }
        cout << endl;<br>    }
    cout << sum << endl;<br>}

(4.2k баллов)