ДАЮ 85 БАЛЛОВ !!!ЯЗЫК ПРОГРАММИРОВАНИЯ ТОЛЬКО PYTHON (ПИТОН) Напишите программу, которая...

0 голосов
75 просмотров

ДАЮ 85 БАЛЛОВ !!!ЯЗЫК ПРОГРАММИРОВАНИЯ ТОЛЬКО PYTHON (ПИТОН) Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел, кратных 6. КТО СКОПИРУЕТ ОТВЕТ НЕВЕРНЫЙ СРАЗУ ПОЛУЧИТ БАН ПОЖАЛУЙСТА ПОБЫСТРЕЕ
УМОЛЯЮ СДЕЛАЙТЕ НА ПИТОНЕ СРОЧНО ПЖ


Информатика | 75 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

N = int(input("n = "))
a = []
a = input().split()
s = 0
for i in range(n):
    a[i] = int(a[i])
    if a[i] % 6 == 0: s = s+a[i]
print('s = ',s)

Пример:
n = 5
15 42 31 24 57
s = 66

(194k баллов)