ИНФОРМАТИКА !!! ПОМОГИТЕ!!!!!! составить программу в паскале, в которой с клавиатуры...

0 голосов
36 просмотров

ИНФОРМАТИКА !!! ПОМОГИТЕ!!!!!!
составить программу в паскале, в которой с клавиатуры вводятся 2 текстовых выражения, вычисляется и печатается длина каждого из них. В первом выражении все буквы "а" заменяются на "о", Во втором выражении все буквы "К" заменяются на ""л


Информатика (41 баллов) | 36 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString('Строка-1:');
  var s2:=ReadlnString('Строка-2:');
  Writeln($'Длина 1-й строки {s1.Length}, второй строки {s2.Length}');
  s1:=s1.Replace('а','о'); Writeln('Строка-1: ',s1);
  s2:=s2.Replace('К','л'); Writeln('Строка-2: ',s2)
end.

Пример
Строка-1: А роза упала на лапу Азора
Строка-2: Карл у Клары украл кораллы
Длина 1-й строки 26, второй строки 26
Строка-1: А розо уполо но лопу Азоро
Строка-2: ларл у ллары украл кораллы
(150k баллов)
0 голосов

Var s1,s2:string; l1,l2,i:integer;
begin
writeln('1 строка:');
readln(s1);
writeln('2 строка:');
readln(s2);
l1:=length(s1);
l2:=length(s2);
writeln('Длина 1-ой строки = ',l1);
writeln('Длина 2-ой строки = ',l2);
for i:=1 to l1 do
 if (s1[i]='А')or(s1[i]='а') then s1[i]:='о';
for i:=1 to l2 do
 if (s2[i]='К')or(s2[i]='к') then s2[i]:='л';
writeln('Изменённые строки:');
writeln(s1);
writeln(s2);
end.

Пример:
1 строка:
АБВГДабвгд
2 строка:
Ку-ка-ре-ку
Длина 1-ой строки = 10
Длина 2-ой строки = 11
Изменённые строки:
оБВГДобвгд
лу-ла-ре-лу

(194k баллов)