Составить программу выполняя которую машина выведет ** экран все целые числа от а до б ...

0 голосов
45 просмотров

Составить программу выполняя которую машина выведет на экран все целые числа от а до б
Program primer
war a: inter;
begin
a: = b


Информатика (18 баллов) | 45 просмотров
Дано ответов: 2
0 голосов

Program primer;
var 
   a,b,i:integer;
begin
   readln(a,b);
   for i:=a to b do 
      write(i,' ');
end.

(332 баллов)
0 голосов

Program z1;
var  a, b, c: integer;
begin 
 writeln('Введите начало диапазона:'); 
 readln(a); 
 writeln('Введите конец диапазона:'); 
readln(b); 
 while a < b do 
 begin   
inc(a); 
   Writeln(a);
  end;
end.

(1.2k баллов)
0

Кто вы, почему вы не ставите вообще пробелов? Это же не возможно читать, а когда у тебя программа в 100 строк, в которой вложенные друг в друга циклы, как ты это читать будешь?

0

уже отредактировал,криво скопировалось

0

Я про то, что отступов нет у строк. Просто совет - лучше делай их.

0

А это правильно?