Напишите программу в Pascal.

0 голосов
35 просмотров

Напишите программу в Pascal.


image

Информатика (32 баллов) | 35 просмотров
Дан 1 ответ
0 голосов

Var s:string;
r:real;
i,j,n:integer;
begin    r:=0;
readln(s);
for i:=1 to length(s) do begin       n:=0;       for j:=1 to length(s) do begin
if s[i]=s[j] then inc(n);
end;
r:=r+1/n;
end;
writeln('количество различных букв = ', r:1:0);
end.

2.          

(275 баллов)
0

там просто значения подставь