Написать программу к задаче: Дано число. Найти сумму и произведение его цифр.

0 голосов
30 просмотров

Написать программу к задаче: Дано число. Найти сумму и произведение его цифр.


Информатика (68 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var n,sum,p: integer;
begin
readln(n);
sum:=0;
p:=1;
while n<>0 do
begin
sum:=sum+n mod 10;
p:=p*(n mod 10);
n:= n div 10;
end;
writeln('сумма цифр: ',sum);
write('произведение: ',p);
end.

(149k баллов)