(8 класс, цикл while) Напишите программу, которая находит сумму четных чисел, больших 5....

0 голосов
111 просмотров

(8 класс, цикл while) Напишите программу, которая находит сумму четных чисел, больших 5. Количество введённых чисел неизвестно, последовательность ввода заканчивается нулём.


Информатика (12 баллов) | 111 просмотров
Дан 1 ответ
0 голосов

Program abc;var a, b : integer;begina:=1;b:=0;while a <> 0 dobeginReadln(a);if (a > 5) and (a mod 2 = 0) thenbeginb:=b+a;end;end;Writeln(b);end.

(1.1k баллов)
0

Program abc;
var a, b : integer;
begin
a:=1;
b:=0;
while a <> 0 do
begin
Readln(a);
if (a > 5) and (a mod 2 = 0) then
begin
b:=b+a;
end;
end;
Writeln(b);
end. // нормальная запись, сорян

0

Спасибо!