Помогите составить программу ** языке Паскаль с помощью Random дано a[i]∈[-13,8] Найти...

0 голосов
45 просмотров

Помогите составить программу на языке Паскаль с помощью Random
дано a[i]∈[-13,8]
Найти произведение нечетных отрицательных чисел
n=5


Информатика (192 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(5,-13,8).Println.Where(t->(t<0) and t.IsOdd).ToArray;<br>  if a.Count>0 then a.Aggregate(1,(i,j)->i*j).Println
  else Writeln(0)
end.

Пример
-2 -6 -6 -7 -13
91
(150k баллов)