Написать программу в Pascal по 2 способам for и while. Задание:Вывести ** экран числа...

0 голосов
62 просмотров

Написать программу в Pascal по 2 способам for и while.
Задание:Вывести на экран числа оканчивающаяся на 3 в промежутке от n до 150


Информатика (100 баллов) | 62 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

While:

var
  n: integer;

begin
  write('Введите начало диапазона (n): ');
  readln(n);
  while n < 150 do
  begin
    if n mod 10 = 3
      then  write(n, ' ');
    n := n + 1; end;
end.


for:

var
  n, i: integer;

begin
  write('Введите начало диапазона (n): ');
  readln(n);
  for i := n to 150 do
    if n mod 10 = 3
      then  write(i, ' ');
end.



image
(2.3k баллов)
0

Блок-схему можете приложить пожалуйста

0 голосов

Program df;
var n:integer;
begin
n:=0;
while n<150 do begin<br>n:=n+3;
writeln(n);
end;
end.

(217 баллов)
0

Это только while?

0

Данное решение вообще не верно. Здесь изначально переменной n присваивается значение 0, а затем она увеличивается на 3, и в итоге выводятся не только числа, оканчивающие на 3 (а выводятся: 3, 6,9,12 и т.д.)