Напишите программу на языке Pascal для следующей задачи: Определить число n, при котором сумма квадратов ряда чисел 1, 2, …, n не превысит некоторого целого числа K, т.е. число K вводится с клавиатуры
//программа определит максимальное n program qwerty; var a, k, sum:integer; begin readln(k); a:=1; while((sum+a*a)<=k) do begin<br>sum:=sum+a*a; a:=a+1; end; writeln(a-1); end.
А что означает sum и какое у него значение?
sum- это сумма квадратов ряда чисел от 1 до n