Написать программу проверки знания истории России(3 вопроса)

0 голосов
30 просмотров

Написать программу проверки знания истории России(3 вопроса)


Информатика (124 баллов) | 30 просмотров
0

Паскаль!

Дан 1 ответ
0 голосов

Var  question :
 array [1..3] of string;
 awns,mark: integer; 
begin   
 writeln('Вопрос 1'+ #10 +'1 - вариант ответа'+ #10 +'2 - вариант ответа'+ #10 +'3 - вариант ответа');   
 readln(awns);   
 // проверяем ответ 
 if awns = 1 then mark := mark + 1;   
 writeln('Вопрос 2'+ #10 +'1 - вариант ответа'+ #10 +'2 - вариант ответа'+ #10 +'3 - вариант ответа');   
 readln(awns);   
 // проверяем ответ   
 if awns = 2 then mark := mark + 1;   
 writeln('Вопрос 3'+ #10 +'1 - вариант ответа'+ #10 +'2 - вариант ответа'+ #10 +'3 - вариант ответа');   
 readln(awns);   
 // проверяем ответ   
 if awns = 3 then mark := mark + 1; 
 // выводим результат   
 writeln(' Вы ответили на ' + mark + ' вопросов из 3'); 
end.

(1.8k баллов)