ПОМОГИТЕ с написанием программы в Pascal. Напишите программу, которая в...

0 голосов
27 просмотров

ПОМОГИТЕ с написанием программы в Pascal.
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 5.


Информатика (52 баллов) | 27 просмотров
Дан 1 ответ
0 голосов

Var
  n, sum, i, a: integer;
begin
  read(n);
  sum = 0;
  for i := 1 to n do
  begin
    read(a);
    if (a mod 5 = 0) then
      sum := sum + a;
  end;
  write(sum);
end.

(14 баллов)