Написать программу, где вводиться число и находитьяс сумма цифр(Паскаль, или Lazarus)

0 голосов
49 просмотров

Написать программу, где вводиться число и находитьяс сумма цифр(Паскаль, или Lazarus)


Информатика (41 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET
//Версия 3.3, сборка 1634
begin
write('сумма цифр: ',abs(ReadInteger('введите число:')).ToString.Select(x->x.ToDigit).Sum);
end.

(149k баллов)
0

А как же быть с числом больше Int32

0

Ошибка времени выполнения: Значение было недопустимо малым или недопустимо большим для Int32.