100 баллов! Составьте программу ** языке паскаль: Вычислите длину(l) отрезка АВ, А(ха,...

0 голосов
18 просмотров

100 баллов! Составьте программу на языке паскаль: Вычислите длину(l) отрезка АВ, А(ха, уа) и В(хв, ув), l=корень из (ха+уа)^2+(хв+ув)^2


Информатика (318 баллов) | 18 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (xa,ya):=ReadReal2('Введите координаты х и у точки А:');
  var (xb,yb):=ReadReal2('Введите координаты х и у точки B:');
  Writeln('Длина отрезка АВ равна ',Sqrt(Sqr(xb-xa)+Sqr(yb-ya)))
end.

Пример
Введите координаты х и у точки А: 3.7 -2.96
Введите координаты х и у точки B: 11 8.4
Длина отрезка АВ равна 13.503318110746
(150k баллов)