Помогите написать программу ** C++

0 голосов
25 просмотров

Помогите написать программу на C++


image

Информатика (5.5k баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
#include
#include

using namespace std;
long int multiplyElements(int Arr[], int n)
{
    long int P = 1;
    if ((Arr[0] < 1) || (Arr[1] < 1))
        P = 0;
    else
        for (int i = 0; i < n; i++)
            if (Arr[i] > 0)
                P = P * Arr[i];
            else
                break;

    return P;
}

int main()
{
    setlocale(LC_ALL, "Russian");
    
    int A[10];
    int B[5];
    long int res;
    srand(time(NULL));

    for (int i = 0; i < 10; i++) {
        A[i] = rand() % 15 - 5;
        cout << setw(4) << A[i];<br>    }
    cout << endl;<br>    for (int i = 0; i < 5; i++) {
        B[i] = rand() % 15 - 5;
        cout << setw(4) << B[i];<br>    }
    cout << endl;<br>
    res = multiplyElements(A, sizeof(A) / sizeof(A[0]));
    if (res == 0) cout << "Массив A начинается с элемента меньше единицы, либо он единственный.\n";<br>    else cout << "Произведение A = " << res << endl;<br>
    res = multiplyElements(B, sizeof(B) / sizeof(B[0]));
    if (res == 0) cout << "Массив B начинается с элемента меньше единицы, либо он единственный.\n";<br>    else cout << "Произведение B = " << res << endl;<br>
    system("pause");
    return 0;
}

(9.4k баллов)