Написать программу, которая во введённой с клавиатуры строке заменяет все маленькие...

0 голосов
78 просмотров

Написать программу, которая во введённой с клавиатуры строке заменяет все маленькие гласные латинские буквы на большие. pascal Пожалуйста можно без массивов.


Информатика (87 баллов) | 78 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Вот, вроде так должно получится)


image
(63 баллов)
0

А без массивов можно?

0 голосов

//PascalABC.NET
var
  s: string;
  i: byte;
  vowels: string = 'aeiouy';
begin
  write('Строка = ');
  readln(s);
  for i := 1 to length(s) do
    if pos(s[i], vowels) <> 0 then s[i] := s[i].ToUpper;
  writeln('После замены = ', s);
end.

(9.4k баллов)
0

а можно как-то без [ ]?